Удаленка для jenkins+selenide+selenoid+allure+docker спецов на 2-3 часа в день. 100% remote! Присоединиться к проекту

Запуск тестов на ios 10 + appium native app

mobile
appium
ios
Теги: #<Tag:0x00007fedbc1f3040> #<Tag:0x00007fedbc1f2eb0> #<Tag:0x00007fedbc1f2d48>

(devnull) #1

Добрый день.

Подскажите, может быть кто-то использует appium 1,6+ для тестирование native app on ios 10(симулятор).

Интересует как вы настраивали и работает ли вообще автоматизация на ios 10?

У меня апп билдится, инсталится на симулятор … но не происходит автоматический старт прилаги :disappointed: ну и плюс в прилаге еще watchOS. согласно гугла (https://forums.developer.apple.com/thread/28732) - похоже на баг эпла с XCTest/XCUITest frameworks, так как в логах аппиума есть ошибка на

XCTRunner[7082]: Enqueue Failure: UI Testing Failure - App accessibility isn’t loaded /Volumes/Data/work/from_git_hub/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgentRunner/UITestingUITests.m 35 1


(Yaroslav Pernerovskyy) #2

Пока не работает. Разработчики аппиума фиксят. Пока что рекомендуют не переходить на иос10.


(devnull) #3

все заработало. все вылечилось после того как я удалил apabilities.setCapability(“bundleId” …
тем самым посзволив апиуму самому задетектить бандл


(aino) #4

Нет новостей?
Не заработало ещё?


(Aleksey Ilyenko) #5

Уже все давно работает. Используйте последние версии аппиума и библиотек


(Pavel Nikitinsky) #6

Используйте XCtest framework в связке с Swift 3


(Dmitry Lemeshko) #7

Добрый день,
столкнулся с той же проблемой, сервер 1.6.3, клиент java-client 4.1.2, Mac OS Sierra
Уже добавил /Users/my_user/Library/Developer/Xcode/DerivedData/WebDriverAgent-adoydtgydzcgafckwqichdlcsifj/Build/Products/Debug-iphonesimulator/WebDriverAgentRunner-Runner.app в исключения в Security & Privacy но каждый раз после запуска эмулятора и установки тестового приложения вылетает security попап с Do you want the application “WebDriverAgentRunner-Runner.app” to accept incoming network connections?
Нажимаю Allow, пытается открыть тестовое приложение, оно сразу же закрывается и потом в консоли сообщение как в первоначальном тикете.
Capabilities:
platformName=iOS
deviceName=iPhone 6s
platformVersion=9.3
automationName=XCUITest
WebDriverAgent я локально не билдил, может это необходимый шаг?
Может знает кто как пофиксить?


(Ray Romanov) #8

Из этого раздела все сделано:


Можно еще дополнить это:


(Dmitry Lemeshko) #9

Пофиксилось после того как переставил все сертификаты и сгенерил новые ключи


(Ray Romanov) #10

Ну не знаю, мне вообще никаких ключей не понадобилось…