В модульном maven проекте не формируются нормально отчеты, не отображаются шаги и названия тестов.

testng
maven
allure
Теги: #<Tag:0x00007fedb8c2c510> #<Tag:0x00007fedb8c2c3d0> #<Tag:0x00007fedb8c2c290>

(Дмитрий Сизов) #1

Проблема в том что после того как проект автотестов стал одним из модулей мавен, с allure стало все совсем плохо.

Раньше запускал тесты mvn clean test, потом mvn allure:serve открывал готовый отчет.

Сейчас руками могу открыть из target/site/allure-maven-plugin, но названия тестов и большая часть шагов не отображаются, несмотря на то что аннотации title и step есть везде.

<?xml version="1.0"?>
<project
		xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"
		xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
	<modelVersion>4.0.0</modelVersion>
	<parent>
		<groupId>com.XXXXXX</groupId>
		<artifactId>XXXXXXX</artifactId>
		<version>0.0.1-SNAPSHOT</version>
	</parent>
	<artifactId>XXXXXX_integration_tests</artifactId>
	<name>XXXXXX_integration_tests</name>
	<url>http://maven.apache.org</url>
	<properties>
		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
		<aspectj.version>1.8.10</aspectj.version>
	</properties>
	<dependencies>
		<dependency>
			<groupId>com.XXXXXXX</groupId>
			<artifactId>XXXXXX_entities</artifactId>
			<version>0.0.1-SNAPSHOT</version>
		</dependency>
		<!-- https://mvnrepository.com/artifact/org.seleniumhq.selenium/selenium-java -->
		<dependency>
			<groupId>org.seleniumhq.selenium</groupId>
			<artifactId>selenium-java</artifactId>
			<version>3.11.0</version>
		</dependency>
		<!-- https://mvnrepository.com/artifact/org.testng/testng -->
		<dependency>
			<groupId>org.testng</groupId>
			<artifactId>testng</artifactId>
			<version>6.14.2</version>
			<scope>test</scope>
		</dependency>
		<dependency>
			<groupId>io.qameta.allure</groupId>
			<artifactId>allure-testng</artifactId>
			<version>2.6.0</version>
			<scope>test</scope>
		</dependency>
		<dependency>
			<groupId>ru.yandex.qatools.allure</groupId>
			<artifactId>allure-java-annotations</artifactId>
			<version>1.5.4</version>
		</dependency>
	</dependencies>
	<build>
		<plugins>
			<plugin>
				<groupId>org.apache.maven.plugins</groupId>
				<artifactId>maven-surefire-plugin</artifactId>
				<version>2.20</version>
				<configuration>
					<argLine>
						-javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"
					</argLine>
				</configuration>
				<dependencies>
					<dependency>
						<groupId>org.aspectj</groupId>
						<artifactId>aspectjweaver</artifactId>
						<version>${aspectj.version}</version>
					</dependency>
				</dependencies>
			</plugin>
			<plugin>
				<groupId>io.qameta.allure</groupId>
				<artifactId>allure-maven</artifactId>
				<configuration>
					<properties>
						<allure.issues.tracker.pattern>http://example.com/%s</allure.issues.tracker.pattern>
					</properties>
				</configuration>
			</plugin>
		</plugins>
	</build>
	<reporting>
		<excludeDefaults>true</excludeDefaults>
		<plugins>
			<plugin>
				<groupId>io.qameta.allure</groupId>
				<artifactId>allure-maven</artifactId>
				<version>2.8</version>
			</plugin>
		</plugins>
	</reporting>
</project>


(Дмитрий Сизов) #2

Разобрался, лишняя зависимость allure-java-annotations.