Удаленка для jenkins+selenide+selenoid+allure+docker спецов на 2-3 часа в день. 100% remote! Присоединиться к проекту

В Jenkins не видит Maven тесты. Пишет Build succes

jenkins
infrastructure
maven
java
webdriver
Теги: #<Tag:0x00007fedb9171160> #<Tag:0x00007fedb9171020> #<Tag:0x00007fedb9170ee0> #<Tag:0x00007fedb9170c88> #<Tag:0x00007fedb9170b48>

(Sigmaren) #1

Добрый день! Не получается запустить тесты через jenkins. Выдает такой лог :


Established TCP socket on 50041
<===[JENKINS REMOTING CAPACITY]===>channel started
Executing Maven: -B -f C:\Auto-tests\AutoTests3\pom.xml clean test
[INFO] Scanning for projects…
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building loginet-test 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] — maven-clean-plugin:2.5:clean (default-clean) @ loginet-test —
[INFO] Deleting C:\Auto-tests\AutoTests3\target
[INFO]
[INFO] — maven-enforcer-plugin:1.0:enforce (enforce-maven) @ loginet-test —
[INFO]
[INFO] — maven-resources-plugin:2.6:resources (default-resources) @ loginet-test —
[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] Copying 5 resources
[INFO]
[INFO] — maven-compiler-plugin:3.6.1:compile (default-compile) @ loginet-test —
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 9 source files to C:\Auto-tests\AutoTests3\target\classes
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/Verify.java: C:\Auto-tests\AutoTests3\src\main\java\helpers\Verify.java uses or overrides a deprecated API.
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/Verify.java: Recompile with -Xlint:deprecation for details.
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/ApplProps.java: C:\Auto-tests\AutoTests3\src\main\java\helpers\ApplProps.java uses unchecked or unsafe operations.
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/ApplProps.java: Recompile with -Xlint:unchecked for details.
[INFO]
[INFO] — maven-resources-plugin:2.6:testResources (default-testResources) @ loginet-test —
[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory C:\Auto-tests\AutoTests3\src\test\resources
[INFO]
[INFO] — maven-compiler-plugin:3.6.1:testCompile (default-testCompile) @ loginet-test —
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 9 source files to C:\Auto-tests\AutoTests3\target\test-classes
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/Verify.java: C:\Auto-tests\AutoTests3\src\main\java\helpers\Verify.java uses or overrides a deprecated API.
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/Verify.java: Recompile with -Xlint:deprecation for details.
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/ApplProps.java: C:\Auto-tests\AutoTests3\src\main\java\helpers\ApplProps.java uses unchecked or unsafe operations.
[INFO] /C:/Auto-tests/AutoTests3/src/main/java/helpers/ApplProps.java: Recompile with -Xlint:unchecked for details.
[INFO]
[INFO] — maven-surefire-plugin:2.20:test (default-test) @ loginet-test —
[INFO]
[INFO] -------------------------------------------------------
[INFO] T E S T S
[INFO] -------------------------------------------------------
[INFO] Running TestSuite
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/C:/Users/tester_2/.m2/repository/org/slf4j/slf4j-simple/1.7.22/slf4j-simple-1.7.22.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/C:/Users/tester_2/.m2/repository/ch/qos/logback/logback-classic/1.2.1/logback-classic-1.2.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.SimpleLoggerFactory]
[INFO] Tests run: 0, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 5.209 s - in TestSuite
[INFO]
[INFO] Results:
[INFO]
[INFO] Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
[INFO]
[JENKINS] Recording test results
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 01:18 min
[INFO] Finished at: 2017-12-27T18:19:46+03:00
[INFO] Final Memory: 31M/112M
[INFO] ------------------------------------------------------------------------
Ожидаю пока Jenkins закончит сбор данных

В Intellij IDEA сам тест запускается. Пробовал менять версии, добавлял строчку с указанием директории, видел также похожую проблему на форуме, но варианты решения по ней не помогли. В каком направлении хотя бы искать проблему…?

POM:


4.0.0
Main
loginet-test
jar
1.0-SNAPSHOT
loginet-test
Allure TestNG and WebDriver Usage Example
http://maven.apache.org

ru.yandex.qatools.allure
allure-examples-parent
1.0


<allure.version>1.5.2</allure.version>
<aspectj.version>1.8.10</aspectj.version>



central
http://central.maven.org/maven2/

<dependencies>
    <dependency>
        <groupId>ru.yandex.qatools.allure</groupId>
        <artifactId>allure-testng-adaptor</artifactId>
        <version>${allure.version}</version>
        <exclusions>
            <exclusion>
                <groupId>junit</groupId>
                <artifactId>junit</artifactId>
            </exclusion>
        </exclusions>
    </dependency>



    <dependency>
        <groupId>org.apache.poi</groupId>
        <artifactId>poi</artifactId>
        <version>3.9</version>
    </dependency>

    <dependency>
        <groupId>org.apache.poi</groupId>
        <artifactId>poi-ooxml</artifactId>
        <version>3.9</version>
    </dependency>
    <dependency>
        <groupId>org.testng</groupId>
        <artifactId>testng</artifactId>
        <version>6.11</version>
        <scope>test</scope>
    </dependency>




    <dependency>
        <groupId>io.github.bonigarcia</groupId>
        <artifactId>webdrivermanager</artifactId>
        <version>1.6.2</version>
    </dependency>

    <dependency>
        <groupId>org.seleniumhq.selenium</groupId>
        <artifactId>selenium-server</artifactId>
        <version>3.3.1</version>
    </dependency>
    <dependency>
        <groupId>org.seleniumhq.selenium</groupId>
        <artifactId>selenium-java</artifactId>
        <version>3.3.1</version>
    </dependency>
    <dependency>
        <groupId>com.microsoft.sqlserver</groupId>
        <artifactId>sqljdbc4</artifactId>
        <version>4.0</version>
        <scope>test</scope>
    </dependency>

    <dependency>
        <groupId>xml-apis</groupId>
        <artifactId>xml-apis</artifactId>
        <version>1.4.01</version>
    </dependency>

    <dependency>
        <groupId>org.slf4j</groupId>
        <artifactId>slf4j-api</artifactId>
        <version>1.7.22</version>
    </dependency>

    <dependency>
        <groupId>org.slf4j</groupId>
        <artifactId>slf4j-simple</artifactId>
        <version>1.7.22</version>
    </dependency>
    <dependency>
        <groupId>org.eclipse.jetty</groupId>
        <artifactId>jetty-maven-plugin</artifactId>
        <version>9.4.4.v20170414</version>
    </dependency>
    <dependency>
        <groupId>junit</groupId>
        <artifactId>junit</artifactId>
        <version>4.13-SNAPSHOT</version>
    </dependency>

    <dependency>
        <groupId>com.codeborne</groupId>
        <artifactId>selenide</artifactId>
        <version>4.6-SNAPSHOT</version>

    </dependency>
    <dependency>
        <groupId>co.mailtarget</groupId>
        <artifactId>logback-appenders</artifactId>
        <version>0.0.2-SNAPSHOT</version>
    </dependency>


</dependencies>



<build>
    <testSourceDirectory>${basedir}/src/main/java</testSourceDirectory>
    <plugins>


        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.6.1</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>



        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-surefire-plugin</artifactId>
            <version>2.20</version>
            <configuration>
                <useFile>false</useFile><!--убрать-->
                <printSummary>true</printSummary>
                <testFailureIgnore>true</testFailureIgnore>
                <argLine>
                    -javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"
                </argLine>
                <includes>
                    <include>**/*Test.java</include>
                </includes>



                <suiteXmlFiles>
                    <file>C:\Auto-tests\AutoTests3\pom2.xml</file>



                    <!--<file>src/test/java/</file>-->


                </suiteXmlFiles>
            </configuration>
            <dependencies>
                <dependency>
                    <groupId>org.aspectj</groupId>
                    <artifactId>aspectjweaver</artifactId>
                    <version>${aspectj.version}</version>
                </dependency>
            </dependencies>
        </plugin>
        <plugin>
            <groupId>org.eclipse.jetty</groupId>
            <artifactId>jetty-maven-plugin</artifactId>
            <version>9.4.4.v20170414</version>
            <configuration>
                <webAppSourceDirectory>${project.build.directory}/site/allure-maven-plugin</webAppSourceDirectory>
                <stopKey>stop</stopKey>
                <stopPort>1234</stopPort>
            </configuration>
        </plugin>
    </plugins>
</build>
<reporting>
    <excludeDefaults>true</excludeDefaults>
    <plugins>
        <plugin>
            <groupId>io.qameta.allure</groupId>
            <artifactId>allure-maven</artifactId>
            <version>2.8</version>
        </plugin>
    </plugins>
</reporting>
    <!--

                    mvn clean test site jetty:run
                    localhost:8180
    -->

(Sigmaren) #2

(Почему-то теги не добавились в начале POM)