t.me/atinfo_chat Telegram группа по автоматизации тестирования

Установка geckodriver на Firefox 48 selenium webdriver

Теги: #<Tag:0x00007f74869d3fa8> #<Tag:0x00007f74869d3ee0> #<Tag:0x00007f74869d3df0> #<Tag:0x00007f74869d3d28> #<Tag:0x00007f74869d3c60>

Здравствуйте. Не запускается selenium на ff 48. В сети пишут что необходимо установить драйвера geckodriver.
Подскажите на win 8.1 где необходимо прописать новые драйвера, чтобы standalone сервер заработал

Я бы пока не устанавливал Геко, он сыроват, лучше откатиться до 45 версии.

1 Симпатия

47.0.1 вроде работает с последним биндингом селениума. Откатился на нее потому что 48 не давала мне ставить дополнения xpi не из маркета. В 47 можно воспользоваться xpinstall.signatures.required и отключить проверку подписи расширений. Кстате, кто пользуется FirePath, не советую обновлять Firebug, новая версия несовместима с FirePath :frowning: - а это лучшее решение по написанию, валидации xpath. Последняя совместимая версия Firebug с FirePath - firebug-2.0.16

1 Симпатия

Тоже столкнулся с этой проблемой. Решением был этот ответ на stackoverflow. А вот geckodrivers в том числе и для Windows.

У меня та же проблема, geckodrivers не устанавливается просто открывается черная консоль и висит… Помогите как все пофиксить.