Удаленка для jenkins+selenide+selenoid+allure+docker спецов на 2-3 часа в день. 100% remote! Присоединиться к проекту

ui тесты в TeamCity запускаются в минимальном разрешениеи 800*600

team-city
infrastructure
Теги: #<Tag:0x00007fedc0794040> #<Tag:0x00007fedc079be30>

(Nikitoz777) #1

Проблема:
ui тесты на Тимсити запускаются в минимальном разрешениеи 800*600

Причина:
билд агент запущен как win сервис, из-за этого gui не видно, даже если залогинится под учеткой агента, т.к. вин сервис использует скрытый десктоп, и вытащить его анрил (но это неточно

Возможное решение:
https://confluence.jetbrains.com/display/TCD9/Known+Issues#KnownIssues-IssueswithautomatedGUIandbrowsertesting

можно ли все таки поменять разрешение экрана в скрытом десктопе?
При этом сервис билд агента запущен от следующих пользователей


(Юрий Аксютин) #2

Смена дифолтного разрешения:

либо запускайте браузер в headless mode - тогда можете указывать разрешение какое захотите


(Nikitoz777) #3

вы пробовали запустить безбашенный режим хрома на агенте? у меня локально все ок, а когда на тимсити, то даже хром не открывает


(Юрий Аксютин) #4

проблема не в агенте, а в том как вы конфигурируете запуск браузера - совпадают ли пути к веб драйверу на вашей локальной машине и на агенте? Возможно не хватает прав на чтение/запись для ваших юзеров на агенте, гадание можно продолжать бесконечно)
я использую Selenium grid


(Nikitoz777) #5

все совпадает, если запускать на ТИМСИТИ в обычном режиме то все ок, а если прописать

ChromeOptions options = new ChromeOptions();
options.AddArgument("–headless");
options.AddArgument("–disable-gpu");
options.AddArgument("–window-size=1920,1080");
options.AddArgument(“no-sandbox”);

то перестает запускаться.


(Юрий Аксютин) #6

Я работаю на C#, конфигурация хрома в headless режиме отличается добавлением одной строчки:
options.AddArgument("–headless");

все остальные параметры одинаковы для обоих режимов. У вас тоже так?
вы предоставляете минимум информации для решения вашего вопроса)


(Nikitoz777) #7

спасибо за отзывчивость :slight_smile:
одной строчкой не получается. вот мой код:

ChromeOptions options = new ChromeOptions();
options.AddArgument("–headless");

_webDriver = new ChromeDriver(Path.GetFullPath(Path.Combine(TestContext.CurrentContext.TestDirectory, @"…\Chromedriver")));


(Юрий Аксютин) #8

можете показать вывод с этими тремя параметрами?
вы используете последнюю версию веб драйвера?


(Nikitoz777) #9

проблема решена. настроил тесты под запуск в хедлесс режиме