Selenium, запуск тестов в chrome при уже открытом браузере

Здравствуйте! Столкнулась со следующей проблемой.
Возникла необходимость запустить тесты на chrome. Запустить получилось, но возник следующий нюанс:

Если запускать тесты, когда браузер закрыт, то всё ок: открывается браузер, тесты проходят успешно.

Если же браузер уже открыт, то при запуске тестов открывается новая вкладка, в строке адреса “data:,”;
если выставлена опция запуска в режиме инкогнито, то открывается новое окно, но в строке адреса это же самое.
Все, на этом тесты стопорятся.

Подскажите, как решить данную проблему?

1 Like

Вот даже не знаю… Вы точно QA? Теперь перечитайте и сами подумайте что человек из вашего письма может узнать. Вот я только узнал, что у вас браузер не открывает новую страницу при открытом другом браузере.
Вот я использую 4 браузера(chrome, firefox, ie, edge), у меня 2 OS. Ubuntu, Windows 10
У меня селениум 3.4 без грида.
И я не сталкивался с таким.

Есть вероятность, что вы некорректно закрываете экземпляр web driver при завершении теста.
Опубликуйте код поднятия/гашения браузера и версии селениума + вебдрайвера, без этого ничего не понятно

1 Like

ответ выискала в другой теме

ByteSurferапр. 2015
Разобрался - почему-то отныне хромдрайвер мне позволяет открывать не более одного инстанса браузера с выбранным профилем, проблема странная, но жить можно. Всем спасибо за ответы.

1 Like

Я после окончанию теста удалял процесс хром браузера. Вот пример кода на c#:

Process [] chromeInstances = Process.GetProcessesByName(“chrome”);

foreach(Process p in chromeInstances)
p.Kill();