t.me/atinfo_chat Telegram группа по автоматизации тестирования

[Resolved] Results Directories для Allure Report

В результате запуска теста xml - файлы формируются в папке target\allure-results.
а сами отчеты в папке target\site\allure-maven-plugin.

какой Results Directories необходимо указать в Jenkinсе, что бы отобразились отчеты?

[INFO] Rendering site with org.apache.maven.skins:maven-default-skin:jar:1.0 skin.
[INFO] Generating "Allure" report    --- allure-maven-plugin:2.0
[INFO] Report Version: 1.4.0
[INFO] Results Pattern: target/allure-results
[INFO] Found [1] results directories by pattern [target/allure-results]
[INFO] Generate report to C:\workspace\Maven_Tests\target\site\allure-maven-plugin
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

[INFO] Report data generated successfully. Unpack report face...
[INFO] Report unpacked successfully.

[JENKINS] Archiving site from C:\workspace\Maven_Tests\target\site to C:\Program Files (x86)\Jenkins\jobs\MavenTest3\site

[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 33.988 s
[INFO] Finished at: 2014-12-16T14:38:18+02:00
[INFO] Final Memory: 28M/68M
[INFO] ------------------------------------------------------------------------
Waiting for Jenkins to finish collecting data
[JENKINS] Archiving C:\workspace\Maven_Tests\pom.xml to Mindfire/Maven_Tests/0.0.1-SNAPSHOT/Maven_Tests-0.0.1-SNAPSHOT.pom
[JENKINS] Archiving C:\workspace\Maven_Tests\target\Maven_Tests-0.0.1-SNAPSHOT.jar to Mindfire/Maven_Tests/0.0.1-SNAPSHOT/Maven_Tests-0.0.1-SNAPSHOT.jar
channel stopped

Allure Report Generation: started
Allure Report Generation: find directories by mask [target]
Allure Report Generation: found allure result directories []
Allure Report Generation: can't find allure results directories
Build step 'Allure Report Generation' marked build as failure
Sending e-mails to: kitten.tester7@gmail.com

Finished: FAILURE

Вообще похожая проблема и у меня возникла. Решение тут. Напишите если получится.

Solved: The problem is because it was not finding the viewroot for clearcase, that is solved by providing the clearcase viewroot in the job configuration.

Извините, а можно подробней?

Вопрос так остался не решен!!!

решен с помощью магии и перехода на svn