Есть отличная удаленная работа для php+codeception+jenkins+allure+docker спецов. 100% remote! Присоединиться к проекту

[Resolved] Не находит элементы(локаторы) на странице при этом падает драйвер

thucydides
internet-explorer
java
webdriver
Теги: #<Tag:0x00007f7b6d1c88e8> #<Tag:0x00007f7b6d1c8780> #<Tag:0x00007f7b6d1c85c8> #<Tag:0x00007f7b6d1c83c0>

(f@zen>) #1

Добрый день! Скажите кто сталкивался с IEDriverDriver.exe (32). Вопрос следующий. При запуске теста

  1. Браузер запускается
  2. После слипа тест падает с чем это связано

Сразу говорю что я сделал для драйвера, потому что IE это очень трудоемкий драйвер по сравнению хром и фокс
Вот тест кейс)

1. Свойства обозревателя (поставил галочки все)
2. Свойства обозревателя (убрал все галочки)

3. Добавил в реестр такой путь

4. Указал путь в файле

System.setProperty("webdriver.ie.driver", "C:\\Test\\Automation testing(art-lemon)\\DriverBrowsers\\IEDriverServer.exe"); 

@Managed(uniqueSession = true, driver = "iexplorer")

5. Добавил надежные сайты

6. Обновил selenium-java

        <dependency>
            <groupId>org.seleniumhq.selenium</groupId>
            <artifactId>selenium-java</artifactId>
            <version>2.45.0</version>
        </dependency>

Я уже не могу представить что еще может быть, помогите разобраться


(vmaximv) #2

(f@zen>) #3

А если нет обновления?


(vmaximv) #4

Тогда еще две попытки:

  1. Включите java script, если он отключен.
  2. Additionally, "Enhanced Protected Mode" must be disabled for IE 10 and higher. This option is found in the Advanced tab of the Internet Options dialog.

Ну а если хотите 100% - давайте логи драйвера и полную трассу эксепшена.


(f@zen>) #5

Да спасибо vmaximv все таки много заморочек в IE , оказывается следовало включить все сценарии js, и убрать галочки “Enhanced Protected Mode” все хорошо работает!


(Максим Малунов) #6

Емнип была какая-то Сapabilities которая отключала всю эту борьбу с защищенными режимами .
С 10 точно работала .

capabilities.setCapability(InternetExplorerDriver.INTRODUCE_FLAKINESS_BY_IGNORING_SECURITY_DOMAINS,true);