t.me/atinfo_chat Telegram группа по автоматизации тестирования

При запуске тестов в Debug моде Rider 2019.1.1 виснет.


(Дмитрий) #1

При запуске тестов в Debug моде Rider 2019.1.1 виснет, все тесты в статусе Pending.
Проблема появилась после перехода на .Net core 3.0
Пробовал переустанавливать .net core и ide, результаты те же.
К сожалению ошибок в консоли нет, как и надежд на решение) Может кто-то уже сталкивался, знает что можно попробовать сделать, Спасибо!

“C:\Program Files\JetBrains\JetBrains Rider 2019.1.1\bin\runnerw64.exe” “C:\Program Files\JetBrains\JetBrains Rider 2019.1.1\lib\ReSharperHost\JetBrains.Debugger.Worker.exe” --mode=client --frontend-port=64598 “–plugins=C:\Program Files\JetBrains\JetBrains Rider 2019.1.1\plugins\rider-unity\dotnetDebuggerWorker”

13:40:15.086 |T| Launch: 15f624a3-5406-46e2-aea8-7991e1a6650b >> RunHostController.AfterLaunchStarted 13:40:15.086 |T| Launch: 15f624a3-5406-46e2-aea8-7991e1a6650b <> RunHostController.PrepareForRun 13:40:31.682 |T| Run: d21b3567-e778-4063-91ff-88db5349bbce << RunHostController.PrepareForRun 13:40:31.682 |T| Register handler for message type 'TestSession.Message', protocol version '1' 13:40:31.682 |T| Register handler for message type 'ProtocolVersion', protocol version '' 13:40:31.682 |T| Register handler for message type 'TestSession.Connected', protocol version '' 13:40:31.682 |T| Register handler for message type 'TestExecution.CustomTestHostLaunch', protocol version '1' 13:40:31.682 |T| Register handler for message type 'TestExecution.Completed', protocol version '1' 13:40:31.682 |T| Register handler for message type 'TestExecution.StatsChange', protocol version '1' 13:40:31.683 |I| [ProcessStartInfoPatchResult] Original request: DotNetCoreRequest Success: True ErrorMessage: Original StartInfo: FileName = 'vstest', Arguments = '/port:50499 ', WorkDir = 'D:\DotNetProjects\Simpligov\Tests' Patched StartInfo: FileName = 'C:\Program Files (x86)\dotnet\dotnet.exe', Arguments = '"vstest" /port:50499 ', WorkDir = 'D:\DotNetProjects\Simpligov\Tests'

13:40:31.683 |I| Starting process: C:\Program Files (x86)\dotnet\dotnet.exe “vstest” /port:50499
13:40:31.685 |I| Started process with pid 13520
13:40:32.093 |T| Processing message ‘TestSession.Connected’
13:40:32.093 |T| Processed message ‘TestSession.Connected’
13:40:32.099 |T| Processing message ‘ProtocolVersion’
13:40:32.099 |T| Processed message ‘ProtocolVersion’
13:40:32.099 |I| Using test adapter: D:\DotNetProjects\Simpligov\Tests\bin\Debug\NUnit3.TestAdapter.dll
13:40:32.100 |T| RunSettings:

<?xml version='1.0' encoding='utf-8'?> .NETCoreApp,Version=v3.0 X64 13:40:32.178 |T| Processing message 'TestExecution.CustomTestHostLaunch' 13:40:32.179 |T| Processed message 'TestExecution.CustomTestHostLaunch' 13:40:32.179 |I| [ProcessStartInfoPatchResult] Original request: DirectRequest Success: True ErrorMessage: Original StartInfo: FileName = 'C:\Program Files (x86)\dotnet\dotnet.exe', Arguments = 'exec --runtimeconfig "D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.runtimeconfig.json" --depsfile "D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.deps.json" "C:\Users\dzmitry.staravoitau\.nuget\packages\microsoft.testplatform.testhost/16.4.0\lib/netcoreapp2.1/testhost.dll" --port 50501 --endpoint 127.0.0.1:050501 --role client --parentprocessid 14648 --telemetryoptedin false', WorkDir = 'D:\DotNetProjects\Simpligov\Tests\bin\Debug' Patched StartInfo: FileName = 'C:\Program Files (x86)\dotnet\dotnet.exe', Arguments = 'exec --runtimeconfig "D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.runtimeconfig.json" --depsfile "D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.deps.json" "C:\Users\dzmitry.staravoitau\.nuget\packages\microsoft.testplatform.testhost/16.4.0\lib/netcoreapp2.1/testhost.dll" --port 50501 --endpoint 127.0.0.1:050501 --role client --parentprocessid 14648 --telemetryoptedin false', WorkDir = 'D:\DotNetProjects\Simpligov\Tests\bin\Debug'

13:40:32.179 |I| Starting process: C:\Program Files (x86)\dotnet\dotnet.exe exec --runtimeconfig “D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.runtimeconfig.json” --depsfile “D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.deps.json” “C:\Users\dzmitry.staravoitau.nuget\packages\microsoft.testplatform.testhost/16.4.0\lib/netcoreapp2.1/testhost.dll” --port 50501 --endpoint 127.0.0.1:050501 --role client --parentprocessid 14648 --telemetryoptedin false
13:40:32.183 |I| Started process with pid 12408
13:40:32.615 |T| Processing message ‘TestSession.Message’
13:40:32.615 |T| Processed message ‘TestSession.Message’
13:40:32.615 |I| NUnit Adapter 3.15.1.0: Test execution started
13:40:32.624 |T| Processing message ‘TestSession.Message’
13:40:32.624 |T| Processed message ‘TestSession.Message’
13:40:32.624 |I| Running selected tests in D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.dll
13:40:32.979 |T| Processing message ‘TestSession.Message’
13:40:32.979 |T| Processed message ‘TestSession.Message’
13:40:32.979 |I| NUnit3TestExecutor converted 1 of 1 NUnit test cases
13:41:05.066 |T| Processing message ‘TestExecution.StatsChange’
13:41:05.066 |T| Processed message ‘TestExecution.StatsChange’
13:41:05.066 |W| Unit-test element not found for test-case <Tests.WorkflowDesigner.T521_DatepickerSpecifiersDateFormat.Test_CheckAllDataAfterInitiatingWorkflow> from <D:\DotNetProjects\Simpligov\Tests\bin\Debug\Tests.dll>
13:41:17.998 |I| Run: d21b3567-e778-4063-91ff-88db5349bbce - is being cancelled
13:41:18.036 |I| Process C:\Program Files (x86)\dotnet\dotnet.exe:13520 has exited with code (0)
Output stream: Microsoft ® Test Execution Command Line Tool Version 16.3.0
Copyright © Microsoft Corporation. All rights reserved.

13:41:18.037 |T| Run: d21b3567-e778-4063-91ff-88db5349bbce >> RunHostController.CleanupAfterRun
13:41:18.037 |T| Run: d21b3567-e778-4063-91ff-88db5349bbce << RunHostController.CleanupAfterRun
13:41:18.037 |I| Run: d21b3567-e778-4063-91ff-88db5349bbce - Cancelled
13:41:18.037 |I| C:\Program Files (x86)\dotnet\dotnet.exe exited
13:41:18.037 |I| RunTestsStage completed
13:41:18.038 |I| FinishLaunchStage started
13:41:18.038 |I| Finishing launch
13:41:18.038 |I| Launch is finished
13:41:18.038 |I| FinishLaunchStage completed
13:41:18.038 |T| Launch: 15f624a3-5406-46e2-aea8-7991e1a6650b >> RunHostController.BeforeLaunchFinished
13:41:18.038 |T| Launch: 15f624a3-5406-46e2-aea8-7991e1a6650b << RunHostController.BeforeLaunchFinished


(Vladislav Abramov) #2

в логе что-то есть, погуглите


(Дмитрий) #3

Спасибо за ответ. Проблема с зависанием в дебаг моде воспроизводилась из-за неправильно выбранной разрядности для .Net core (по ошибке ставил х86). Пожелаем мне внимательности, всем удачи)