Ошибка запуска хрома на удаленном сервере

webdriver
testng
selenium
Теги: #<Tag:0x00007fedbabc66a0> #<Tag:0x00007fedbabc6560> #<Tag:0x00007fedbabc63a8>

(Александр Клевцов) #1

Здравствуйте! Столкнулся с такой проблемой, автотесты прекрасно запускаются и работают на локальной машине, но на удаленном сервере, с той же версией селениума и хромдрайвера происходит следующее:

05:00:36.058 WARN - Exception: unknown error: Chrome failed to start: exited abnormally
(Driver info: chromedriver=2.25.426924 (649f9b868f6783ec9de71c123212b908bf3b232e),platform=Linux 2.6.32-042stab120.11 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 60.20 seconds
Build info: version: ‘2.53.1’, revision: ‘a36b8b1’, time: ‘2016-06-30 17:37:03’
System info: host: ‘test’, ip: ‘185.159.131.222’, os.name: ‘Linux’, os.arch: ‘amd64’, os.version: ‘2.6.32-042stab120.11’, java.version: ‘1.7.0_121’
Driver info: org.openqa.selenium.chrome.ChromeDriver

не могу понять в чем дело, до этого хром в принципе не запускался под рутом, под обычным пользователем проблема ушла(отчаявшись в запуске под рутом, пробовал запускать через Xvfb), возможно проблема как раз в Xvfb, который больше мне не нужен, но пока победить проблему не получается.


(Vasiliy Rakshin) #2

Версия Хрома какая?
У хромдрайвера уже такая - https://chromedriver.storage.googleapis.com/index.html?path=2.27/


(Александр Клевцов) #3

Version 55.0.2883.87
а версия хромдрайвера 2.25


(Александр Клевцов) #4

а на локальной тачке хром Версия 54.0.2840.100 (64-bit)
Может быть из за этого проблема?


(Vasiliy Rakshin) #5

Обновите хромдрайвер.


(zaleg) #6

Привет.
Стыкался с этой проблемой(начиная с Chrome 54) и она не только у тебя, после гугления нашел такое:
https://groups.google.com/forum/#!topic/chromedriver-users/2pxHCAINxX0

После downgrade chrome на 52 + ChromeDriver 2.23 все работает отлично.


(Александр Клевцов) #7

Спасибо, сейчас буду пробовать разные комбинации хрома и хромдрайвера, по результатам отпишусь!)


(Александр Клевцов) #8

Перепробовал варианты комбинаций селениум сервера (2.53.1 и 3.0.1) и хромдрайвера(2.25 - 2.27), что к сожалению не помогло решить проблему. Подскажите где найти более старые версии хрома?