Есть отличная удаленная работа для php+codeception+jenkins+allure+docker спецов. 100% remote! Присоединиться к проекту

Jenkins + Ant + Junit проблема в кодировке


(streLer) #1

Ребят помогите пожалуйста, Запускаю проект , все хорошо, но пробелма с кодировкой выводится примерно так

[junit] FM-??????????? RITMIX FMT-A750, USB, SD, ??????? HDD, ?????
    [junit] ?????? ??? ?????????, 20 ?., BRAUBERG "Kids Series" (???????? "??????? ?????"), "Ocean Love"
    [junit] ?????? BALLET CLASSIC ?3, 80 ?/?2, 500 ?., ColorLok, ????? "?", ??????????, ??????? 97%, 153% (CIE)
    [junit] ?????? COLOR COPY GLOSSY, ?????, ??????????, ?????????, ?4, 135 ?/?2, 250 ?., ????? "?++", ???????
    [junit] ?????? COLOR COPY, ?????, ?4, 160 ?/?2, 250 ?., ??? ???????????? ??????, ????? "?++", ???????
    [junit] ?????? ??????? ?1 (610?860 ??), 200 ?/?2, ?????? ?-??., ? ??????? ??????

, если запускую на своей машине в Эклипсе то в консоле все нормально выводится


(AlexAlex) #2

Где именно текст выводится в нечитаемом виде? Уточните, пожалуйста.

А также дайте информацию о том где какие кодировки у вас используются/указаны?


(streLer) #3


(streLer) #4

возможно ли из-за того что не стоит русская локализация на Сервере? 


(Mykhailo Poliarush) #5

а там где Вы запускаете, что за ОС стоит?

попробуйте на этой ОС вручную запустить билд.

тоже самое получиться или нет?

чтобы определить хотя бы это ant или jenkins


(streLer) #6

Стоит Linux. Red Hat. 

в ручную не пробовал, надо попробовать =)


(Mykhailo Poliarush) #7

ну попробуйте вручную и напишите, что получилось


(streLer) #8

Все поправили)) нужно было кодировки настроить на Сервере


(Mykhailo Poliarush) #9

ну напиши уже тогда что и где в системе вы поправили, что у вас все заработало

чтобы другие потом тоже знали как решать подобную проблему


(streLer) #10

Делали по этому Мануалу 

http://pingvinus.ru/note/windows-fonts-in-ubuntu