Есть отличная удаленная работа для php+codeception+jenkins+allure+docker спецов. 100% remote! Присоединиться к проекту

Downgrade Appium до более ранних версий


(Natalja Librante Lace) #1

Appium версии 1.2.2. установлен на OS X 10.8.5 (Mavericks), Xcode 5.1.1.
Тестировать Android-приложение было невозможно из-за бага с выводом в окно скрытого текста
Баг вроде как был исправлен в Appium 1.2.3. На сегодняшний день последняя версия Appium - 1.2.4.

Однако после апдейта аппиума с помощью нода, установилась версия 1.3.0-beta1. Можно ли убрать бета-версию аппиума и поставить 1.2.4 версию без переинссталяции инструмента (так как первоначальная установка потребовала привлечения сторонних сил, чего делать снова не хотелось бы)?

Это решение с version-manager уже пробовала. У меня не получилось сделать так, чтобы оно заработало (нод у меня установлен через brew, если это принципиально, appium - нет)


(Hackett) #2

https://www.npmjs.org/doc/cli/npm-uninstall.html

user$ npm install appium@1.2.3 --global


(Natalja Librante Lace) #3

Спасибо!