Allure Report unknown. unknown - unknown (0s)

allure
Теги: #<Tag:0x00007f7b6210e908>

(Golovanoff) #1

Добрый день.

Адаптера allure для нашей системы тестирования (самописка на 1с) нет, поэтому формирую *-testsuite.xml руками, скармливаю их аллюру (allure generate). Все формируется, показывается, красота, тренды, все дела.

На странице Overview 2 сьюта, с именами, вроде все ок. При открытии сьютов - показываются их History, Retries. можно “провалиться” в шаги, для которых показывается время их выполнения:

Но тут же на скрине видно, что общая продолжительность сьюта не считается - показывается 0s, хотя справа для шагов есть время выполнения.

И на Overview отчет показывается вот так:

Такая же странность и в хистори:

В xml файлике вроде все как надо:

<?xml version="1.0" encoding="UTF-8"?>
<test-suite xmlns="urn:model.allure.qatools.yandex.ru" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="1.6" stop="1547727301000" start="1547727251000">
	<name xmlns="">INTIC-2610</name>
	<title xmlns="">INTIC-2610</title>
	<test-cases xmlns="" xmlns:d2p1="urn:model.allure.qatools.yandex.ru">

Атрибуты start и stop заполнены.

Allure стоит сейчас 2.9.0.

Подскажите, плиз, как побороть эти “unknown at unknown”? Откуда allure их берет? Каких данных и где ему не хватает?
Вроде все уже перерыл, обгуглился весь - не могу понять, что упустил.


(Vladislav Abramov) #2

vanessa behavior, silverbulleters add погуглите, это тестовые фреймворки для 1с, там везде аллюр есть и оттуда можно взять allure-config json