t.me/atinfo_chat Telegram группа по автоматизации тестирования

Allure - No project URL defined - decoration links will not be relativized! так же после не создает папку allure-results

allure
java
selenide
Теги: #<Tag:0x00007fb2f68f5560> #<Tag:0x00007fb2f68f6640> #<Tag:0x00007fb2f68f76d0>

(Eye 'S) #1

Не могу разобраться в allure для своего проекта.
Излазил интернет и не нашел что именно делаю не так.

Переменные среды JAVA_HOME, JAVA_MAVEN есть.

Использую IntelliJ IDEA, JAVA, MAVEN, SELENIDE, JUNIT4, ALLURE.

Выполняю mvn clean test и получаю это:

"C:\Program Files\Java\jdk-12.0.2\bin\java.exe" -Dmaven.multiModuleProjectDirectory=C:\Users\levoschkin\Desktop\vk "-Dmaven.home=C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven3" "-Dclassworlds.conf=C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven3\bin\m2.conf" "-Dmaven.ext.class.path=C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven-event-listener.jar" "-javaagent:C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\lib\idea_rt.jar=11793:C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\bin" -Dfile.encoding=UTF-8 -classpath "C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven3\boot\plexus-classworlds-2.6.0.jar" org.codehaus.classworlds.Launcher -Didea.version2019.3.2 test
[INFO] Scanning for projects...
[WARNING] 
[WARNING] Some problems were encountered while building the effective model for org.example:vkTest:jar:1.0
[WARNING] 'dependencies.dependency.version' for org.testng:testng:jar is either LATEST or RELEASE (both of them are being deprecated) @ line 34, column 22
[WARNING] 
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING] 
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
[WARNING] 
[INFO] 
[INFO] -------------------------< org.example:vkTest >-------------------------
[INFO] Building vkTest 1.0
[INFO] --------------------------------[ jar ]---------------------------------
[INFO] 
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ vkTest ---
[WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build is platform dependent!
[INFO] Copying 0 resource
[INFO] 
[INFO] --- maven-compiler-plugin:3.8.1:compile (default-compile) @ vkTest ---
[INFO] Nothing to compile - all classes are up to date
[INFO] 
[INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ vkTest ---
[WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build is platform dependent!
[INFO] skip non existing resourceDirectory C:\Users\levoschkin\Desktop\vk\src\test\resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.8.1:testCompile (default-testCompile) @ vkTest ---
[INFO] Changes detected - recompiling the module!
[WARNING] File encoding has not been set, using platform encoding UTF-8, i.e. build is platform dependent!
[INFO] Compiling 1 source file to C:\Users\levoschkin\Desktop\vk\target\test-classes
[INFO] 
[INFO] --- maven-surefire-plugin:3.0.0-M4:test (default-test) @ vkTest ---
[INFO] 
[INFO] -------------------------------------------------------
[INFO]  T E S T S
[INFO] -------------------------------------------------------
[INFO] Running vkTest
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Starting ChromeDriver 79.0.3945.36 (3582db32b33893869b8c1339e8f4d9ed1816f143-refs/branch-heads/3945@{#614}) on port 32443
Only local connections are allowed.
Please protect ports used by ChromeDriver and related test frameworks to prevent access by malicious code.
янв. 27, 2020 12:07:40 PM org.openqa.selenium.remote.ProtocolHandshake createSession
INFO: Detected dialect: W3C
[INFO] Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 6.423 s - in vkTest
[INFO] 
[INFO] Results:
[INFO] 
[INFO] Tests run: 1, Failures: 0, Errors: 0, Skipped: 0
[INFO] 
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  11.527 s
[INFO] Finished at: 2020-01-27T12:07:43+03:00
[INFO] ------------------------------------------------------------------------

Вот все что делает проект:

Папки в target - allure-results - нет

Вот pom.xml:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>org.example</groupId>
    <artifactId>vkTest</artifactId>
    <version>1.0</version>

    <properties>
        <aspectj.version>1.9.4</aspectj.version>
    </properties>

    <dependencies>
        <dependency>
            <groupId>io.qameta.allure</groupId>
            <artifactId>allure-junit4</artifactId>
            <version>2.13.0</version>
        </dependency>
        <dependency>
            <groupId>com.codeborne</groupId>
            <artifactId>selenide</artifactId>
            <version>5.5.1</version>
        </dependency>
        <dependency>
            <groupId>org.slf4j</groupId> <!-- логирование -->
            <artifactId>slf4j-simple</artifactId>
            <version>2.0.0-alpha1</version>
        </dependency>
        <dependency>
            <groupId>org.testng</groupId>
            <artifactId>testng</artifactId>
            <version>RELEASE</version>
            <scope>test</scope>
        </dependency>
    </dependencies>


    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-surefire-plugin</artifactId>
                <version>3.0.0-M4</version>
                <dependencies>
                    <dependency>
                        <groupId>org.aspectj</groupId>
                        <artifactId>aspectjweaver</artifactId>
                        <version>${aspectj.version}</version>
                    </dependency>
                </dependencies>
                <configuration>
                    <includes>
                        <include>vkTest.java</include>  <!-- какой тест запускать -->
                    </includes>
                    <testFailureIgnore>true</testFailureIgnore>
                    <argLine>
                        -javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"
                    </argLine>
                    <properties>
                        <property>
                            <name>listener</name>
                            <value>io.qameta.allure.junit4.AllureJunit4</value>
                        </property>
                    </properties>
                    <systemProperties>
                        <property>
                            <name>allure.result.directory</name><!-- куда -->
                            <value>${project.build.directory}/target/allure-results</value>
                        </property>
                    </systemProperties>
                </configuration>
            </plugin>
            <plugin>
                <groupId>io.qameta.allure</groupId>
                <artifactId>allure-maven</artifactId>
                <version>2.10.0</version>
            </plugin>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.8.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                </configuration>
            </plugin>
        </plugins>
    </build>

</project>

Пробывал полный путь ставить для папки - все равно ничего.

В итоге после выполнения allure report - ошибка

Directory C:\Users\levoschkin\Desktop\vk\target\allure-results not found.

В переменных средах создавал такие переменные:

  1. allure
    C:\Program Files\Java\allure-commandline-2.13.0\allure-2.13.0\bin

  2. JAVA_HOME
    C:\Program Files\Java\jdk-12.0.2

  3. MAVEN_HOME
    C:\Program Files\Java\Maven\apache-maven-3.6.3

  4. Path
    %JAVA_HOME%\bin;%MAVEN_HOME%\bin;


(Vasily) #2

Попробуйте в configuration для maven-surefire-plugin (а не systemProperties):

<systemPropertyVariables>  
    <allure.results.directory>${project.build.directory}\allure-results</allure.results.directory>       
</systemPropertyVariables>

ну и в properties закомментируйте пока allure.results.directory


(Eye 'S) #3

Изменил так:

<configuration>

                    <testFailureIgnore>false</testFailureIgnore>
                    <argLine>-javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"</argLine>
                    <properties>
                        <property>
                            <name>listener</name>
                            <value>io.qameta.allure.junit4.AllureJunit4</value>
                        </property>
                    </properties>
                   <!-- <systemProperties>
                        <property>
                            <name>allure.results.directory</name>
                            <value>${project.build.directory}/allure-results</value>
                        </property>
                    </systemProperties>  -->
                    <systemPropertyVariables>
                        <allure.results.directory>${project.build.directory}\allure-results</allure.results.directory>
                    </systemPropertyVariables>
                </configuration>

После использовал mvn clean --> mvn test и вот результат:

"C:\Program Files\Java\jdk1.8.0_131\bin\java.exe" -Dmaven.multiModuleProjectDirectory=D:\AutoTesting "-Dmaven.home=C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven3" "-Dclassworlds.conf=C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven3\bin\m2.conf" "-Dmaven.ext.class.path=C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven-event-listener.jar" "-javaagent:C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\lib\idea_rt.jar=6998:C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\bin" -Dfile.encoding=UTF-8 -classpath "C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2019.2.1\plugins\maven\lib\maven3\boot\plexus-classworlds-2.6.0.jar" org.codehaus.classworlds.Launcher -Didea.version2019.3.1 test
[INFO] Scanning for projects...
[INFO] 
[INFO] ----------------------< AutoTesting:AutoTesting >-----------------------
[INFO] Building AutoTesting 1.0-SNAPSHOT
[INFO] --------------------------------[ jar ]---------------------------------
[INFO] 
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ AutoTesting ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 0 resource
[INFO] 
[INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ AutoTesting ---
[INFO] Nothing to compile - all classes are up to date
[INFO] 
[INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ AutoTesting ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory D:\AutoTesting\src\test\resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.1:testCompile (default-testCompile) @ AutoTesting ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 3 source files to D:\AutoTesting\target\test-classes
[INFO] 
[INFO] --- maven-surefire-plugin:3.0.0-M4:test (default-test) @ AutoTesting ---
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  1.949 s
[INFO] Finished at: 2020-01-09T16:49:45+03:00
[INFO] ------------------------------------------------------------------------

В итоге в папке target НЕ появилась папка allure-results.
2020-01-09_1623


(Vasily) #4

Так тесты не запустились…


(Eye 'S) #5

В каком порядке я должен все сделать?


(Vasily) #6

Так у вас сами-то тесты запускаются?


(Eye 'S) #7

у меня всего один тест и отдельно запускается и выполняется успешно.

2020-01-09_1623


(Vasily) #8

У вас имя класса с тестом/тестами должен быть таким:

  • **/Test*.java
  • **/*Test.java
  • **/*Tests.java
  • **/*TestCase.java
    Чтобы maven-surefire-plugin мог его запустить.

(Eye 'S) #9

Простите, но где про это можно почитать? тк я не понял где именно указывать /Test.


(Vasily) #10

CreateIngoing.java -> CreateIngoingTest.java


(Eye 'S) #11

Исправил названия и добавил в pom. Так же обновил все данные в этом вопросе.


(Eye 'S) #12

нашел еще способ добавить папку не через Пом. Но он тоже не увенчался успехом


(Vasily) #13

Ну так мой комментарий самый верхний (про systemPropertyVariables) почему в итоге не сделали?


(Eye 'S) #14

Добавил сюда настройку, результата не дало.

<configuration>
                    <includes>
                        <include>vkTest.java</include>  <!-- какой тест запускать -->
                    </includes>
                    <testFailureIgnore>true</testFailureIgnore>
                    <argLine>
                        -javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"
                    </argLine>
                    <properties>
                        <property>
                            <name>listener</name>
                            <value>io.qameta.allure.junit4.AllureJunit4</value>
                        </property>
                    </properties>
                    <systemPropertyVariables>
                        <allure.results.directory>${project.build.directory}\allure-results</allure.results.directory>
                    </systemPropertyVariables>
                    <!--   <systemProperties>
                           <property>
                               <name>allure.results.directory</name> куда
                            <value>${project.build.directory}/target/allure-results</value>
                        </property>
                    </systemProperties>-->
                </configuration>

(Eye 'S) #15

Просто я думал что созданная allure properties за это отвечает.
2020-01-27_1209


(Vasily) #16

Я вас могу только отослать к документации - https://docs.qameta.io/allure/#_junit_4
Сравнивайте версии библиотек, вижу у вас что-то уж совсем новьё, а что-то устарело.
https://docs.qameta.io/allure/#_configuration - по поводу настроек (возможно надо слэш на обратный поменять?..)